Adminconsole US degraded. Admins may have issues adding users.
Incident Report for Foxit
Resolved
This incident is resolved. A deployment image error was discovered and several fixes have been in place to prevent it from happening again.
Posted Jun 05, 2023 - 20:12 PDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2023 - 16:37 PDT
Investigating
Adminconsole US degraded. Admins may have issues adding users. We're aware of this issue and we're investigating it.
Posted Jun 05, 2023 - 16:29 PDT