Foxit Support Ticket System is Inaccessible for Some Users
Incident Report for Foxit
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 18:57 PDT
Investigating
Some users are currently unable to submit support tickets via the Foxit Support Page. If you cannot get through the Foxit Support Portal, please call the Foxit Support Number: 1-866-693-6948. We are currently investigating the issue.
Posted Mar 25, 2024 - 13:45 PDT
This incident affected: Foxit.com.