Idox.ai MOBILE Issue Identified May, 27, 2024
Incident Report for Foxit
Resolved
An issue was found in code deployed and fixed.
Posted May 27, 2024 - 23:57 PDT
Identified
We have identified an issue with our idox.ai mobile application. If you are using an iPhone, you may see Internal Server Error in your browser. We are actively working to correct the problem.
Posted May 27, 2024 - 13:32 PDT