eSign US : Signed Documents and Forms not functioning properly
Incident Report for Foxit
Resolved
During the week of December 19, 2024, signed documents and executed forms are not functioning properly. Some forms fail to load, while others load but do not display the information entered by the signer.

The issue occurred during the following timeframe:

12/10/2024: 11:46 to 16:45 PT


We implemented a fix, and the situation has returned to normal.
Posted Dec 10, 2024 - 16:51 PST
Identified
Multiple eSign customers reporting that signed documents and executed forms are not working correctly. Some forms fail to load, while others load but do not display the signer-entered information.

eSign dev and cloud ops teams are actively working on the issue.
Posted Dec 10, 2024 - 12:06 PST