FoxiteSign UI Partial Disruption (Limited Users)

Incident Report for Foxit

Resolved

During the week of May 07, 2025, some customers experienced an outage with Foxit eSign services.
The outages occurred during the following timeframes:

05/07/2025: 08:04 AM to 12:34 PM UTC

We determined the cause was related to a deployment that experienced degraded performance.
Posted May 07, 2025 - 17:31 PDT

Update

The issue has been resolved
Posted May 07, 2025 - 05:34 PDT

Identified

We are aware that some users may be experiencing UI issues on the eSign platform. Our team has identified the root cause and is actively working on a fix. Thank you for your patience.
Posted May 07, 2025 - 04:15 PDT