Subscription Activations and some other foxit.com service issues have been Identified Sept 15, 2023
Incident Report for Foxit
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 12:12 PDT
Identified
We have identified an issue with foxit.com application. We are actively working to correct the problem.
Posted Sep 15, 2023 - 05:12 PDT