AdminConsole EU is currently experiencing a bug
Incident Report for Foxit
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 09:53 PDT
Investigating
There is a bug in adminconsole EU that doesnt allow the user to invite people. We are investigating the issue
Posted Mar 22, 2023 - 08:00 PDT