Foxit Cloud Services Major Interruption Jan 4, 2024 1:01am-1:21am
Incident Report for Foxit
Resolved
The below Foxit cloud services were down Jan 4, 2024 1:01am-1:21am:
Account/CAS
Admin Console US, EU, CA
eSign US, EU, CA
PDF Editor Cloud US
Foxit.com Official Website
AppStore
CWS

This was due to human error while updating routing tables. We are putting in safeguards to restrict this type of access in the future. Thank you for your patience.
Posted Jan 03, 2024 - 23:58 PST
Update
We are continuing to monitor for any further issues.
Posted Jan 03, 2024 - 22:28 PST
Monitoring
We apologize for a 20 minute outage of most Foxit Cloud Services. Services are back up, and we are investigating the root cause.
Posted Jan 03, 2024 - 22:28 PST