eSign webhook down: Customers many not receive eSign api status updates

Incident Report for Foxit

Resolved

The incident has been resolved
Posted May 22, 2025 - 14:12 PDT

Monitoring

A fix has been implemented and will be monitoring closely.
Posted May 22, 2025 - 11:13 PDT

Investigating

We are currently investigating the issue.
Posted May 22, 2025 - 10:43 PDT