Foxit.com Sign-In Issues
Incident Report for Foxit
Resolved
This incident has been resolved. Users may have had issues logging in to foxit.com and purchasing subscription between 10:20am ET to 12:15pm ET on May 3rd. This was due to a memory issue and has been fixed.
Posted May 03, 2023 - 09:51 PDT
Identified
We are currently investigating the issue. Some users may receive a 500 error when logging in and have issues purchasing subscriptions.
Posted May 03, 2023 - 09:07 PDT