Some Admin Console users have had their licenses revoked unexpectedly. We are investigating the issue.

Incident Report for Foxit

Resolved

We have resolved this issue. If you have issues with a license deactivation, please reach out to us immediately.
Posted May 28, 2024 - 23:24 PDT

Identified

Thank you for your patience. We are taking this matter very seriously.
Posted May 27, 2024 - 23:59 PDT

Investigating

We are currently investigating this issue.
Posted May 27, 2024 - 08:28 PDT