Foxit.com/shopping is currently unreachable
Incident Report for Foxit
Resolved
This incident has been resolved. During 7:46am ET - 8:22am customers may have received a 500 error when navigating to foxit.com/shopping. This was due to a memory issue on one of our database services.
Posted Sep 12, 2023 - 06:18 PDT
Investigating
Foxit.com/shopping is currently unreachable, we are looking into the situation.
Posted Sep 12, 2023 - 06:18 PDT