PDF Editor MAC downloads slow
Incident Report for Foxit
Resolved
Downloads are back to normal, thank you for your patience.
Posted May 09, 2023 - 12:28 PDT
Investigating
Download link for pdf mac ver. is extremely slow. We're aware of this issue and we're investigating it.
Posted May 09, 2023 - 07:26 PDT