Foxit.com Online Store Checkout Issue Identified May 24, 2023
Incident Report for Foxit
Resolved
This incident is resolved. Issue due to code exception. Complete RCA can be available upon request.
Posted May 24, 2023 - 18:32 PDT
Identified
We have identified an issue for some transactions checking out of our Online Store where the amount is not shown. We are actively working to correct the problem.
Posted May 24, 2023 - 10:15 PDT