Major Issues with eSign US identified
Incident Report for Foxit
Resolved
This incident has been resolved. An issue was found with our iText server and working with development team to resolve permanently.
Posted Feb 26, 2024 - 23:33 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2024 - 18:21 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 26, 2024 - 18:07 PST
Identified
We have identified an issue with our eSign US application. We are actively working to correct the problem.
Posted Feb 26, 2024 - 18:07 PST