US/EU Foxit Editor services degradations

Incident Report for Foxit

Resolved

This incident has been resolved.
Posted Aug 17, 2023 - 18:13 PDT

Monitoring

A fix was implemented on 8/16 7am MT. Only a handful of customers were impacted when trying to sign in from PDF Editor Desktop. Please reach out to customer service if you are experiencing issues. Thank you for your patience.
Posted Aug 16, 2023 - 15:41 PDT

Update

A fix was implemented on 8/16 7am MT. Only a handful of customers were impacted when trying to sign in from PDF Editor Desktop. Please reach out to customer service if you are experiencing issues. Thank you for your patience.
Posted Aug 16, 2023 - 10:05 PDT

Investigating

We are currently investigating this issue.
Posted Aug 16, 2023 - 07:23 PDT