Users are unable to activate account
Incident Report for Foxit
Resolved
The AdminConsole team has fixed this issue and is expected to send a fix at 3pm Beijing time.
This incident will then been resolved.
Posted Feb 29, 2024 - 19:48 PST
Investigating
There have been reports that users are unable to activate their account. We are currently investigating the Issue
Posted Feb 29, 2024 - 11:59 PST
This incident affected: US AdminConsole.