Renewed CloudBlue customers unable to access Admin Console

Incident Report for Foxit

Resolved

This incident has been resolved.
Posted Jul 09, 2024 - 10:17 PDT

Investigating

Multiple partners are reporting that their customer's subscription has expired even though it should have auto renewed.
Posted Jul 08, 2024 - 14:50 PDT