Account.foxit.com having issues impacting most cloud services Apr 9, 2024
Incident Report for Foxit
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 23:17 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 09, 2024 - 21:36 PDT
Investigating
We are currently investigating this issue.
Posted Apr 09, 2024 - 21:28 PDT
This incident affected: US eSign, EU eSign, CA eSign, US AdminConsole, EU AdminConsole, CA AdminConsole, US PDF Editor Cloud, EU PDF Editor Cloud, CA PDF Editor Cloud, and Foxit.com.