Adminconsole is degraded. eSign is effected
Incident Report for Foxit
Resolved
Admin Console Infrastructure has been upgraded to account for high traffic. The problem has been resolved
Posted Feb 29, 2024 - 08:23 PST
Update
We are continuing to investigate this issue.
Posted Feb 29, 2024 - 07:35 PST
Investigating
Adminconsole.foxit.com is currently under high stress and is slow/degraded. As a result, eSign has also beed effected. We are currently investigating
Posted Feb 29, 2024 - 07:31 PST
This incident affected: US eSign and US AdminConsole.