Editor + users unable to access eSign
Incident Report for Foxit
Resolved
The Incident has been resolved. All subscriptions have been restored and is functioning normally. Thank You
Posted Jan 28, 2025 - 11:05 PST
Monitoring
Update: Root cause identified.

A bug was found in request data sent from subscription to eSign, where the start time is equal to the expiration time, leading to malfunctions. All subscriptions are expected to be fixed around 5am ET.
Posted Jan 27, 2025 - 22:34 PST
Identified
Many PDF Editor+ users' eSign licenses have expired today. We are working on a solution.
Posted Jan 27, 2025 - 15:42 PST