Download Link Issue Identified Jul 22, 2022
Incident Report for Foxit
Resolved
This incident has been resolved.
Posted Jul 23, 2022 - 06:24 UTC
Identified
Some customers may have issues with "expired" download links. We are actively working to correct the problem. We invite you to visit https://pdfonline.foxit.com to also do work.
Posted Jul 22, 2022 - 16:57 UTC